Массовая печать документов Word

Распечатка документов из word


Знаете ли вы, какой текстовый редактор пользуется самой большой популярностью в России? Конечно же, это продукт компании Microsoft – MS Word. Это удобная программа, позволяющая создавать и редактировать различные текстовые документы. Она, с одной стороны, проста в использовании, а с другой имеет массу возможностей для редактирования текста. Кроме того распечатка документов word на листах формата А4 возможна на обычном офисном принтере. Но если вам кажется, что нет ничего проще, чем провести с помощью ворд печать документов, вы заблуждаетесь. В процессе переноса информации на бумажные носители могут возникнуть досадные неприятности: сбиться нумерация страниц, исчезнуть или «съехать» изображение, размещенное в текстовом файле. Опытные мастера печати знают, как избежать подобных недоразумений и сделать так, чтобы распечатка документов word была проведена без ошибок с первого раза.
Текстовый редактор Ворд: печать документов без проблем
Сотруднику офиса сложно представить свой рабочий день без этой программы. В MS Word готовятся служебные записки, договоры, отчеты, бланки писем. И чаще всего электронная версия составленного в текстовом редакторе документа должна быть распечатана на бумаге. В некоторых случаях объем печати может быть настолько велик, что проще передать работу подрядчику, чем отнимать время и силы у сотрудников офиса.
В копицентре первое, чем поинтересуются при оформлении заказа, — в каком формате будут представлены электронные документы. Лучше всего сдавать исходный файл в pdf. Это и есть та небольшая хитрость, которая позволяет сотрудникам копировального центра без труда выполнять такую операцию, как распечатка документов word. В текстовом редакторе есть специальная функция, с помощью которой документ в формате doc буквально за пару действий конвертируется в pdf. Сохраненный в таком формате, электронный документ будет одинаково открываться в любом редакторе для просмотра изображений и в точности соответствовать исходнику. Еще один важный момент – документ невозможно будет отредактировать или изменить его содержание. Переведя файл в pdf из ворд, печать документов можно осуществить быстро и без ошибок.
Особенности пакетной печати документов word
Когда требуется напечатать большое количество документов, сохраненных отдельными файлами, или надо распечатать определенный диапазон листов из разных файлов, сделать это можно с помощью такой операции, как пакетная печать документов word. Специальные утилиты, установленные на компьютере, позволяют программировать печать в таком режиме, который фактически представляет собой полуавтоматический процесс с минимальным вмешательством человека. Только представьте себе, что у вас есть 10 тыс файлов, в каждом из которых надо напечатать лишь первую страницу. Так вот пакетная печать документов word позволяет без проблем выполнить эту и подобные ей задачи. Всего лишь надо прописать путь к папке и задать диапазон печати, а остальное машина выполнит сама.
Бытует мнение, что текстовые документы А4 вполне можно распечатать без участия подрядчика, самостоятельно. Но не всегда это удобно и оправдано с экономической точки зрения. В любом случае, в копировальном центре себестоимость печати будет ниже, чем в офисе. Если надо быстро перенести на бумагу большой объем текстовой документации, то услуги копицентра будут весьма кстати. А в условиях, когда проект «горит» и времени в обрез, опыт сотрудников и производственные мощности профессионального печатного центра станут просто бесценными. Таким образом, если вам часто приходится тиражировать документы, лучше иметь на примете одного-двух подрядчиков, к которым в любой момент можно обратиться за помощью на этом сайте.

Массовая печать документов

По просьбе бухгалтеров была написана эта обработка. Умеет печатать или сохранять печатные формы документов. Предлагает на выбор печать на принтер, вывод на экран или сохранение в указанный каталог, Есть возможность задать формат (PDF,DOCX,XLS,XLSX) в котором сохранить печатную форму. Обработка не притендует на универсальность, так как требует внесения изменений в конфигурацию.

// Общий модуль — Универсальные механизмы // Процедура НапечататьДокумент(ПечДокумент, КоличествоЭкземпляров = 1, НаПринтер = Ложь, Заголовок = «», НепосредственнаяПечать = Ложь, Ссылка = Неопределено, ИмяМакета = «») Экспорт Если ПечДокумент = Неопределено тогда Возврат; КонецЕсли; // Получить необходимое количество копий Если КоличествоЭкземпляров > 0 Тогда ПечДокумент.КоличествоЭкземпляров = КоличествоЭкземпляров; КонецЕсли; Если НЕ ПечДокумент.АвтоМасштаб И НЕ ЗначениеЗаполнено(ПечДокумент.ИмяПринтера) Тогда ПечДокумент.АвтоМасштаб = Истина; КонецЕсли; Если ТипЗнч(НаПринтер) = Тип(«Булево») Тогда Если НаПринтер Тогда ПечДокумент.Вывод = ИспользованиеВывода.Разрешить; ПечДокумент.Напечатать(НепосредственнаяПечать = Истина); Иначе ФормаПечати = ПолучитьОбщуюФорму(«ФормаПечати»,, Заголовок + ИмяМакета + Ссылка); ФормаПечати.Документ = Ссылка; ФормаПечати.Заголовок = Заголовок; ФормаПечати.ИмяМакета = ИмяМакета; ФормаПечати.ПечатныйДокумент = ПечДокумент; ФормаПечати.Открыть(); КонецЕсли; ИначеЕсли ТипЗнч(НаПринтер) = Тип(«СписокЗначений») Тогда Каталог = НаПринтер.Получить(0).Значение; Формат = НаПринтер.Получить(1).Значение; ИмяФайла = НаПринтер.Получить(2).Значение; ПечДокумент.Записать(Каталог+ИмяФайла,Формат); ИначеЕсли ТипЗнч(НаПринтер) = Тип(«Массив») Тогда ПечДокумент.Вывод = ИспользованиеВывода.Разрешить; ПечДокумент.Напечатать(НепосредственнаяПечать = Истина); НаПринтер.Добавить(ПечДокумент); ИначеЕсли ТипЗнч(НаПринтер.Значение) = Тип(«Строка») Тогда Если НаПринтер.Значение = «На экран (Предварительный просмотр)» тогда ФормаПечати = ПолучитьОбщуюФорму(«ФормаПечати»,, Заголовок + ИмяМакета + Ссылка); ФормаПечати.Документ = Ссылка; ФормаПечати.Заголовок = Заголовок; ФормаПечати.ИмяМакета = ИмяМакета; ФормаПечати.ПечатныйДокумент = ПечДокумент; ФормаПечати.Открыть(); Иначе ПечДокумент.Имяпринтера = СокрЛп(НаПринтер); ПечДокумент.Вывод = ИспользованиеВывода.Разрешить; ПечДокумент.Напечатать(НепосредственнаяПечать = Истина); КонецЕсли; КонецЕсли; //Если НаПринтер Тогда // ПечДокумент.Напечатать(НепосредственнаяПечать = Истина); //Иначе // // Отобразить печатный документ на экране // //ФормаПечати = ПолучитьОбщуюФорму(«ФормаПечати»,, Новый УникальныйИдентификатор); // ФормаПечати = ПолучитьОбщуюФорму(«ФормаПечати»,, Заголовок + ИмяМакета + Ссылка); // ФормаПечати.Документ = Ссылка; // ФормаПечати.Заголовок = Заголовок; // ФормаПечати.ИмяМакета = ИмяМакета; // ФормаПечати.ПечатныйДокумент = ПечДокумент; // ФормаПечати.Открыть(); //КонецЕсли; КонецПроцедуры // НапечататьДокумент()

Проверял на работоспособнуть на платформе 8.2.19 и выше. Точно могу сказать на платформе 8.2.13 не работает так как нет поддержки PDF.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *