Mikrotik ограничение скорости на порту

Ограничение скорости всем пользователям подсети

Допустим у нас есть входной интернет канал 20 Мбит/с. Мы хотим каждому пользователю подсети сделать ограничение скорости 2 Мбит/с на загрузку и отдачу.

Добавим pcq очередь на загрузку с ограничением 2 Мбит/с.

  1. Откройте меню Queues.
  2. Перейдите на вкладку Queue Types.
  3. Нажмите синий плюсик.
  4. В поле Type Name укажите название очереди на загрузку pcq-download-2M.
  5. В списке Kind выберите pcq.
  6. В поле Rate укажите ограничение скорости на загрузку 2M (2 Мбит/с).
  7. Проверьте, что напротив Dst. Address стоит галочка.
  8. Нажмите кнопку OK.

Добавим pcq очередь на отдачу с ограничением 2 Мбит/с.

  1. Нажмите синий плюсик.
  2. В поле Type Name укажите название очереди на загрузку pcq-upload-2M.
  3. В списке Kind выберите pcq.
  4. В поле Rate укажите ограничение скорости на отдачу 2M (2 Мбит/с).
  5. Поставьте галочку напротив Src. Address.
  6. Уберите галочку напротив Dst. Address.
  7. Нажмите кнопку OK.

Теперь добавим правило с ограничениями скоростей.

  1. Перейдите на вкладку Simple Queues.
  2. Нажмите синий плюсик.
  3. На вкладке General в поле Name укажите название правила queue-limit-2M.
  4. В поле Target укажите нашу подсеть 192.168.88.0/24
  5. В поле Max Limit в колонке Target Upload укажите максимальную скорость отдачи 18M (18 Мбит/с), которую мы выделяем на всю подсеть.
    Если ваш интернет канал равен 20 Мбит/с, то значение нужно указать на 5-20% меньше, например, 18 Мбит/с, чтобы правила сработали. Иначе скорость будет упираться в шейпер провайдера и правила срабатывать не будут.
  6. В поле Max Limit в колонке Target Download укажите максимальную скорость загрузки 18M (18 Мбит/с), которую мы выделяем на всю подсеть.
  7. Перейдите на вкладку Advanced.
  8. В списке Queue Type в колонке Target Upload выберите pcq-upload-2M.
  9. В списке Queue Type в колонке Target Download выберите pcq-download-2M.
  10. Нажмите кнопку OK.

Теперь проверьте на компьютере скорость с помощью сайта www.speedtest.net или аналогичного мобильного приложения на смартфоне.

Ограничение скорости по IP адресу определенному пользователю

Если вам нужно определенному пользователю, например, директору сделать скорость выше чем у остальных, то выполните следующее:

  1. Откройте меню Queues.
  2. На вкладке Simple Queues нажмите синий плюсик.
  3. В появившемся окне на вкладке General в поле Name укажите название ограничения boss.
  4. В поле Target пропишите IP адрес компьютера, для которого будет действовать ограничение.
  5. В поле Max Limit в колонке Target Upload укажите необходимую скорость отдачи.
  6. В поле Max Limit в колонке Target Download укажите необходимую скорость загрузки.
  7. Нажмите кнопку OK.

Если у вас есть правило, которое ограничивает скорость для всех пользователей подсети, то правило для определенного пользователя нужно поднять выше этого правила, чтобы оно сработало. Для этого перетяните его левой кнопкой мыши вверх.

Теперь запустите на компьютере директора speedtest и проверьте скорость. Если на компьютере запустить закачку, то скорость в MikroTik можно посмотреть на вкладке Traffic:

  1. Откройте правило и перейдите на вкладку Traffic.
  2. В поле Rate в колонке Target Upload видим скорость отдачи.
  3. В поле Rate в колонке Target Download видим скорость загрузки.

DHCP сервер через какое-то время может назначить компьютеру другой IP адрес, если истечет время его аренды. Поэтому для указанного IP адреса перестанут действовать необходимые ограничения. Чтобы этого не произошло, нужно привязать IP адрес к MAC адресу конкретного устройства. Как это сделать, написано ниже.

Ограничение скорости всем «качальщикам»

Роутер MikroTik позволяет сделать настройку так, что при просмотре интернет страничек каждый клиент получит максимальную скорость, а как только начнет качать большие файлы, его скорость уменьшится. Для этого настраивается взрывная скорость Burst.

Допустим у нас есть входной интернет канал 20 Мбит/с. Мы хотим, чтобы каждый пользователь по возможности просматривал интернет странички с максимальной скоростью 20 Мбит/с. Но как только он начнет качать большие файлы, его скорость уменьшилась до 3 Мбит/с.

Добавим pcq очередь на загрузку с параметрами Burst.

  1. Откройте меню Queues.
  2. Перейдите на вкладку Queue Types.
  3. Нажмите синий плюсик.
  4. В поле Type Name укажите название очереди на загрузку pcq-burst-download.
  5. В списке Kind выберите pcq.
  6. В поле Rate укажите скорость на загрузку 3M (3 Мбит/с), которая будет действовать, если пользователь начнет качать файлы. Значение Rate должно быть меньше значения Burst Rate.
  7. В поле Burst Rate укажите максимальную скорость на загрузку 18M (18 Мбит/с), которая будет по возможности действовать для просмотра интернет страничек, пока пользователь не начнет качать файлы. Если два пользователя будут одновременно просматривать интернет странички, то 18 Мбит/с поделятся между ними. Каждый получит скорость по 9 Мбит/с. Если скорость вашего интернет-канала 20 Мбит/с, то скорость Burst Rate нужно ставить немного меньше, например, 18 Мбит/с, чтобы правила не уперлись в шейпер провайдера и сработали.
  8. В поле Burst Threshold укажите скорость 2M (2 Мбит/с), при превышении которой начнет действовать ограничение скорости Rate 3M. Значение Burst Threshold должно быть меньше значения Rate.
  9. В поле Burst Time укажите время для подсчета средней скорости загрузки 64. Роутер будет вычислять скорость каждую 1/16 периода. Например, при Burst Time=16 роутер будет вычислять каждую 1 сек, а при Burst Time=32 будет вычислять каждые 2 сек.
    Фактическое время, через которое сработает ограничение на загрузку вычисляется по формуле Real Time = Burst Threshold * (Burst Time / Burst Rate). В нашем случае ограничение сработает через Real Time = 2 * (64 / 20) = 6,4 секунды.
    Для тестирования работы Burst рекомендую сначала поставить большим значение Burst Time. Например, для данного случая лучше поставить Burst Time=192. При этом значении ограничение скорости сработает через 19,2 секунды. Это позволит запустить торрент на компьютере и посмотреть, как будет срабатывать Burst.
  10. Проверьте, что напротив Dst. Address стоит галочка.
  11. Нажмите кнопку OK.

Добавим pcq очередь на отдачу с параметрами Burst.

  1. Нажмите синий плюсик.
  2. В поле Type Name укажите название очереди на отдачу pcq-burst-upload.
  3. В списке Kind выберите pcq.
  4. В поле Rate укажите скорость на отдачу 3M (3 Мбит/с), которая будет действовать, если пользователь начнет передавать файлы в интернет. Значение Rate должно быть меньше значения Burst Rate.
  5. В поле Burst Rate укажите максимальную скорость на отдачу 18M (18 Мбит/с), которая будет по возможности действовать для просмотра интернет страничек, пока пользователь не начнет передавать файлы в интернет.
  6. В поле Burst Threshold укажите скорость 2M (2 Мбит/с), при превышении которой начнет действовать ограничение скорости Rate 3M. Значение Burst Threshold должно быть меньше значения Rate.
  7. В поле Burst Time укажите время для подсчета средней скорости отдачи 64.
    Для тестирования работы рекомендую сначала поставить большим значение Burst Time=192. При этом значении ограничение скорости сработает через 19,2 секунды. Это позволит запустить торрент на компьютере и посмотреть, как будет срабатывать Burst.
  8. Поставьте галочку напротив Src. Address.
  9. Уберите галочку напротив Dst. Address.
  10. Нажмите кнопку OK.

Теперь добавим в Simple Queues правило с ограничениями.

  1. Перейдите на вкладку Simple Queues.
  2. Нажмите синий плюсик.
  3. На вкладке General в поле Name укажите название правила queue-burst-limit.
  4. В поле Target укажите нашу подсеть 192.168.88.0/24
  5. Перейдите на вкладку Advanced.
  6. В списке Queue Type в колонке Target Upload выберите pcq-burst-upload.
  7. В списке Queue Type в колонке Target Download выберите pcq-burst-download.
  8. Нажмите кнопку OK.

Теперь проверьте на компьютере скорость с помощью сайта www.speedtest.net. Она должна стремиться к максимальной 18 Мбит/с. После этого поставьте на закачку торрент и посмотрите, как измениться скорость. Если вы использовали Burst Time=192, то через 20 секунд после старта закачки торрента скорость упадет до 3 Мбит/с.

Ограничение скорости определенному «качальщику» по IP адресу

MikroTik позволяет по IP адресу ограничить скорость определенному пользователю, который качает большие файлы из интернета. Пока пользователь будет смотреть интернет странички, скорость будет высокой, но как только начнет качать файлы, то скорость уменьшится. Для этого настраивается взрывная скорость Burst.

Допустим, мы хотим, чтобы пользователь просматривал интернет странички с максимальной скоростью 20 Мбит/с. Но как только он начнет качать большие файлы, его скорость уменьшилась до 3 Мбит/с.

  1. Откройте меню Queues.
  2. На вкладке Simple Queues нажмите на синий плюсик.
  3. В поле Name укажите имя ограничения dima-burst-limit-3M.
  4. В поле Target укажите IP адрес пользователя 192.168.88.254, для которого будет действовать ограничение.
  5. В поле Max Limit в столбце Target Upload укажите скорость отдачи файлов в интернет 3M (3 Мбит/с). Она должна быть меньше Burst Limit.
  6. В поле Max Limit в столбце Target Download укажите скорость загрузки файлов из интернета 3M (3 Мбит/с). Она должна быть меньше Burst Limit.
  7. В поле Burst Limit в столбце Target Upload укажите максимальную скорость отдачи 20M при просмотре интернет страничек. Она должна быть больше скорости Max Limit.
  8. В поле Burst Limit в столбце Target Download укажите максимальную скорость загрузки 20M при просмотре интернет страничек. Она должна быть больше скорости Max Limit.
  9. В поле Burst Threshold в столбце Target Upload укажите скорость отдачи 2M, при превышении которой, сработает ограничение скорости Max Limit. Значение Burst Threshold должно быть меньше скорости Max Limit.
  10. В поле Burst Threshold в столбце Target Download укажите скорость загрузки 2M, при превышении которой, сработает ограничение скорости Max Limit. Значение Burst Threshold должно быть меньше скорости Max Limit.
  11. В поле Burst Time в столбце Target Upload укажите время для подсчета средней скорости отдачи 64.
    Роутер будет вычислять скорость каждую 1/16 периода. Например, при Burst Time=16 роутер будет вычислять каждую 1 сек, а при Burst Time=32 будет вычислять каждые 2 сек.
    Фактическое время, через которое сработает ограничение вычисляется по формуле Real Time = Burst Threshold * (Burst Time / Burst Rate). В нашем случае ограничение сработает через Real Time = 2 * (64 / 20) = 6,4 секунды.
    Для тестирования работы Burst рекомендую сначала поставить большие значения Burst Time. Например, для данного случая лучше поставить Burst Time=192. При этом значении ограничение скорости сработает через 19,2 секунды. Это позволит запустить торрент на компьютере и посмотреть, как будет срабатывать Burst.
  12. В поле Burst Time в столбце Target Download укажите время для подсчета средней скорости загрузки 64.
  13. Нажмите кнопку OK.

На практике это правило будет работать следующим образом. Пользователь будет просматривать странички в интернете с максимальной скоростью 20 Мбит/с. Когда он начнет качать торренты и средняя скорость превысит 2 Мбит/с, то отключится ограничение 20 Мбит/с, и включится ограничение 3 Мбит/с.

Если у вас есть Burst правило для всей подсети, то правило для определенного пользователя нужно поднять выше него. Для этого перетащите его левой кнопкой мыши.

Распределение скорости интернета поровну

Этот способ подходит для использования на домашнем роутере или в небольшом офисе.

Допустим у вас есть входной интернет канал 20 Мбит/с. В доме есть компьютер сына, ноутбук отца и планшет у мамы. Когда сын начнет качать торренты, нужно чтобы он не занял весь интернет канал. При этом отец смог смотреть фильм онлайн, а мама открывать интернет странички. Но если в сети работает только компьютер сына, то он получит всю доступную скорость интернета 20 Мбит/с.

В данном примере скорость будет делиться поровну, только если все трое начнут качать на максимальной скорости. В этом случае каждый получит скорость около 6,7 Мбит/с (20/3).

Но если отец будет качать файл на скорости 4 Мбит/с, а мать на скорости 2 Мбит/с, то сын получит остальные 14 Мбит/с. Т.е. скорость распределится пропорционально загрузке.

Добавим правило с ограничением скорости.

  1. Откройте меню Queues.
  2. Перейдите на вкладку Simple Queues.
  3. Нажмите синий плюсик.
  4. На вкладке General в поле Name укажите название правила queue-limit.
  5. В поле Target укажите IP адрес подсети 192.168.88.0/24. Если адрес вашей подсети отличается, то укажите необходимый.
  6. В поле Max Limit в колонке Target Upload укажите максимальную скорость отдачи 18M (18 Мбит/с), которую мы выделяем на всю подсеть.
    Значение Max Limit нужно указывать на 5-10% меньше, чем скорость интернета. Если ваша скорость интернета равна 20 Мбит/с, то значение Max Limit нужно указать 18 Мбит/с, чтобы правила сработали. Иначе скорость будет упираться в шейпер провайдера и правила не будут срабатывать.
  7. В поле Max Limit в колонке Target Download укажите максимальную скорость загрузки 18M (18 Мбит/с), которую мы выделяем на всю подсеть.
  8. Перейдите на вкладку Advanced.
  9. В списке Queue Type в колонке Target Upload выберите очередь pcq-upload-default.
    Эти очереди используют алгоритм PCQ, который позволяет равномерно распределить скорость между всеми пользователями вне зависимости от количества открытых подключений.
  10. В списке Queue Type в колонке Target Download выберите очередь pcq-download-default.
  11. Нажмите кнопку OK.

Теперь запустите закачки на компьютерах в сети и посмотрите, как будет распределяться скорость.

Данный способ настройки очень простой, но имеет один недостаток. Если сын включит закачку торрентов, то на его компьютере станут плохо открываться интернет странички или будут задержки в онлайн играх. Чтобы это не происходило, необходимо трафику присваивать различные приоритеты. Например, интернет страничкам и онлайн играм дать более высокий приоритет, чем закачке файлов. Как это сделать, читайте ниже.

Распределение скорости интернета поровну с приоритезацией трафика

Этот способ позволит распределить интернет поровну между всеми пользователями, и дать более высокий приоритет для просмотра интернет страничек, Youtube, ICQ и других сервисов. Поэтому они не будут тормозить, даже если вы поставили на закачку торренты.

Весь трафик разделим по приоритетам на 4 группы:

  • LOW — низкий (торренты, p2p и т.д.)
  • NORMAL — нормальный (интернет странички (HTTP), видео на Youtube (HTTPS) и т.д.)
  • HIGH — высокий (ICQ, Jabber, SSH, Telnet и т.д.)
  • SUPER-HIGH — очень высокий (онлайн-игра Counter Strike, DNS, PING и т.д.)

Алгоритм работы будет такой:

  1. Маркируем все неизвестные соединения LOW.
  2. В соединениях пакеты на загрузку помечаем LOW-DOWNLOAD
  3. В соединениях пакеты на отдачу помечаем LOW-UPLOAD.
  4. Известные соединения маркируем в зависимости от сервиса: NORMAL, HIGH или SUPER-HIGH.
  5. В соединениях пакеты на загрузку помечаем NORMAL-DOWNLOAD, HIGH-DOWNLOAD или SUPER-HIGH DOWNLOAD.
  6. В соединениях пакеты на отдачу помечаем NORMAL-UPLOAD, HIGH-UPLOAD или SUPER-HIGH-UPLOAD.
  7. Создаем PCQ очереди, которые позволят равномерно делить скорость между всеми пользователями. Мы их будем использовать в правилах ограничения скорости.
  8. Создаем правила ограничения скорости в дереве Queue Tree.
    В правилах используем помеченные пакеты, которым задаем приоритет и PCQ очереди.
    Максимальную скорость указываем с помощью родителей DOWNLOAD — 18Мбит/с и UPLOAD — 18Мбит/с.
    Помеченным пакетам присваиваем следующие приоритеты:
  • DOWNLOAD — 18M
    • SUPER-HIGH-DOWNLOAD — приоритет 1
    • HIGH-DOWNLOAD — приоритет 2
    • NORMAL-DOWNLOAD — приоритет 3
    • LOW-DOWNLOAD — приоритет 4
  • UPLOAD — 18M
    • SUPER-HIGH-UPLOAD — приоритет 1
    • HIGH-UPLOAD — приоритет 2
    • NORMAL-UPLOAD — приоритет 3
    • LOW-UPLOAD — приоритет 4

Приступим к настройке.

Добавим пару Layer7 наборов для определения http трафика.

Данные наборы анализируют трафик, пытаются найти в нем указанные последовательности и определить, что это http трафик, gif файл, png файл или jpg файл.

Откройте меню New Terminal и выполните следующие команды:

/ip firewall layer7-protocol

add name=HTTP regexp=»http/(0\\.9|1\\.0|1\\.1) |post * http/\\.»

add name=GIF_FILE regexp=gif

add name=PNG_FILE regexp=png

add name=JPG_FILE regexp=jpg

Для определения HTTP трафика я специально не маркирую трафик на 80 порту, а применяю Layer7, поскольку кроме браузера другие программы могут использовать 80-й порт. Если маркировать трафик по 80 порту, то все получат одинаковый приоритет, и интернет странички не будут быстро грузиться.

Много наборов Layer7 лучше не использовать, т.к. они существенно нагружают роутер.

В меню IP — Firewall на вкладке Layer7 Protocols отобразятся добавленные типы трафика.

По умолчанию промаркируем весь незнакомый трафик, как низкий — LOW.

/ip firewall mangle

add action=accept chain=forward comment=»############## LOW #############» disabled=yes

add action=mark-connection chain=forward comment=ALL-TRAFFIC disabled=no new-connection-mark=LOW passthrough=yes

add action=accept chain=forward comment=»############## END LOW #########» disabled=yes

Добавим маркировку трафика NORMAL.

/ip firewall mangle

add action=accept chain=forward comment=»############## NORMAL #########» disabled=yes

add action=accept chain=forward comment=»############## END NORMAL ############» disabled=yes

Добавим маркировку трафика HIGH:

/ip firewall mangle

add action=accept chain=forward comment=»############## HIGH ############» disabled=yes

add action=accept chain=forward comment=»############## END HIGH ##########» disabled=yes

Добавим маркировку трафика SUPER-HIGH:

/ip firewall mangle

add action=accept chain=forward comment=»############## SUPER-HIGH ##########» disabled=yes

add action=accept chain=forward comment=»############## END SUPER-HIGH ##########» disabled=yes

Чтобы в онлайн игре CounterStrike не было лагов (запаздываний), я добавил ее порты 27005,27014-27025,27035,52046-52048,52146, протокол udp и пометил соединения, как SUPER-HIGH. Если вам нужно добавить другую онлайн игру, узнайте какие порты и протокол она использует, и добавьте свое правило.

В меню IP — Firewall на вкладке Mangle отобразятся добавленные правила маркировки трафика.

Добавим IP адрес нашей подсети и адреса соседних локальных сетей в список Address List:

/ip firewall

address-list add address=192.168.88.0/24 disabled=no list=LAN

address-list add address=192.168.0.0/16 disabled=no list=LAN-EXCEPTION

address-list add address=10.0.0.0/8 disabled=no list=LAN-EXCEPTION

LAN — это список с IP адресами нашей сети 192.168.88.0/24. Укажите другой, если адрес вашей подсети отличается. Этот адрес нужен, чтобы правила маркировали трафик пользователей нашей сети.

LAN-EXCEPTION — список сетей, при обмене данными с которыми не будут работать ограничения скорости.
Например, вы находитесь с другим компьютером в подсети одного провайдера, и хотите скачать с него файл. Ограничивать скорость такой загрузки нет смысла, поскольку компьютер находится не где-то в интернете, а в одной с вами кабельной сети. Поэтому целесообразно, чтобы файл с него качался на максимальной скорости.
192.168.0.0/16 — это адреса локальных подсетей класса С.
10.0.0.0/8 — это подсеть провайдера.

Проверьте на вкладке Address Lists, что подсети добавились.

Добавим PCQ очереди на загрузку и отдачу.

Они используют алгоритм PCQ, который позволяет равномерно распределить скорость между всеми пользователями вне зависимости от количества открытых подключений.

/queue type

Посмотрите созданные очереди в меню Queues на вкладке Queue Types.

Построим дерево Queue Tree и присвоим приоритеты промаркированным пакетам.

  • DOWNLOAD — 18M
    • SUPER-HIGH-DOWNLOAD — приоритет 1
    • HIGH-DOWNLOAD — приоритет 2
    • NORMAL-DOWNLOAD — приоритет 3
    • LOW-DOWNLOAD — приоритет 4
  • UPLOAD — 18M
    • SUPER-HIGH-UPLOAD — приоритет 1
    • HIGH-UPLOAD — приоритет 2
    • NORMAL-UPLOAD — приоритет 3
    • LOW-UPLOAD — приоритет 4

/queue tree

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=18M name=UPLOAD parent=global priority=8

add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=SUPER-HIGH-UPLOAD packet-mark=SUPER-HIGH-UPLOAD parent=UPLOAD priority=1 queue=PCQ-UPLOAD

max-limit=18M — это максимальная скорость 18 Мбит/с на всю подсеть. Укажите свою скорость.
Значение max-limit нужно указывать на 5-10% меньше, чем скорость интернета. Если ваша скорость интернета равна 20 Мбит/с, то значение max-limit нужно указать 18 Мбит/с, чтобы правила сработали. Иначе скорость будет упираться в шейпер провайдера и правила не будут срабатывать.

Посмотрите созданное дерево на вкладке Queue Tree. Здесь видно, с какой скоростью в данный момент передается и принимается каждый вид трафика.

Настройка queues mikrotik

В этой статье не будем глубоко погружаться в типы очередей (queue types) и больше времени уделим практике. Еще раз повторю что все что будет здесь показано актуально и для cloud core router и для любого другого микротока, работающего на RouterOS. И так для настройки ограничений скорости по каким-либо критериям в микротике есть раздел Queues в нем есть две вкладки это «Simple Queues» и «Queue Tree».

В Simple Queues – или простые очереди, нельзя гибко приоритезировать трафик, в большинстве случаем используют этот тип очереди, так как он прост в настройке и дает достаточно большой функционал.

Queue Tree – или дерево очередей, это уже более высокий уровень здесь можно реализовать такие схемы как например, sip трафику отдать высокий приоритет, http чуть ниже а торрентам самый низкий. В таком случае если кто-то начнет качать фильмец через торрент и одновременно будут телефонные звонки – качество этих звонков не пострадает так как их пакеты будут обрабатываться в первую очередь.

Если у вас еще не куплен микротик и вы хотите заранее потренироваться в его настройке, разверните у себя на виртуальной машине eve-ng эмулятор и пробуйте все конфигурации на нем, также конечно стоит настроить Firewall так как вирусов и различных атак на просторах интернета полно.

Во вкладке Queue Types находятся алгоритмы обработки трафика такие как:

  • Bfifo
  • Pfifo
  • Sfq
  • Mq pfifo
  • Pcq

Скажу так в 95% случаем вы, да и все, кто доходит до настройки очередей использует PCQ.

Простыми словами если вы выбираете этот алгоритм в микротике, он поровну разделит скорость доступа в интернет между всеми участниками.

Например, создадим простою очередь на сеть 192.168.13.0\24 и выставим ограничения для нее в 10Mb\s.

В такой ситуации если два ПК начнут пользоваться интернетом, первый качать торрент второй просто серфить в интернете, то для второго все будет очень печально так как торрент съест все установленные нами 10Mb\s. Посмотрим на примере:

Без указания PCQ.

Как видим ПК 1 съедает почти весь трафик скачкой торрент файла и ПК 2 почти ничего не достаётся. А представим, что компьютеров в организации 100?! Тогда будет вообще очень плохо. Теперь поменяем всего два параметра во вкладке Advanced.

Для исходящего и входящего трафика поставим Queue Type pcq-upload-default и pcq-download-default и сымитируем такую-же ситуации для теста.

С указанием PCQ.

Видим, что скорость поделилась почти поровну, используйте это в своей практике.

Расширенные настройки Mikrotik RouterOS: ограничение скорости по IP адресу

Порой возникает необходимость ограничить в скорости, доступ к всемирной сети Интернет тому или иному компьютеру или устройству, находящемуся в вашей локальной сети. Для беспроводного оборудования Mikrotik это можно вполне просто сделать средствами Mikrotik RouterOS. Для этого в утилите Winbox мы переходим в раздел Queues, в котором включаем вкладку Simple Queues. Здесь при помощи кнопки “+” мы создаем новое правило.

На вкладке General, в поле Name указываем произвольное имя нашего ограничения, например имя владельца компьютера, который мы будем ограничивать в скорости. В поле Target Address мы вписываем тот IP, к которому и будут применены ограничения. А в полях Max Limit, мы указываем максимальную скорость отдачи, в поле под Max Upload, и скорость приема, в поле под Max Download. И сохраняем настройки кнопкой Ok.

На снимке экрана выше, видно, что мы ограничили скорость для IP адреса 192.168.0.109 в пределах 10Мбит на скачивание и 5Мбит на отдачу.

Но при помощи привил Queues в Mikrotik RouterOS можно создавать более сложные ограничения. Например, вам надо ограничить скорость приема, только в том случае, когда пользователь начинает качать большие файлы. Эта задача решается следующим образом: как и в первом случае, на вкладке Simple Queues, мы создаем новое правило, нажатием на кнопку “+”. В открывшемся окне, даем имя новому правилу, или оставляем его присвоенным по умолчанию. После чего, в поле Target Address мы вписываем IP адрес, к которому будет применяться ограничение, а в поля Max Limit вписываем наши лимиты, точно так же, как и в первом примере. Однако на этот раз, мы еще заполняем поля в параметре Brust. Где мы видим 3 поля по 2 значения в каждом. В первом поле Burst Limit мы указываем скорость, с которой пользователь будет посещать веб-страницы и осуществлять прочие действия в сети, не превышая лимит. Первое значение под Target Upload, это скорость отдачи, а второе — Target Download, это скорость загрузки данных. Вписываем сюда, например скорость канала предоставляемого нам провайдером, или оставляем параметр unlimited, что означает — “без ограничений”. Второе поле Burst Threshold, это скорость при превышении которой, пользователю будет ограничена скорость. В соответствии с предыдущими полями, мы указываем наш предел скорости под Target Upload для скорости отдачи, и под Target Download, для скорости загрузки. Последним полем, является Burst Time, где мы в секундах указываем время, через которое будет включено ограничение при условии превышения лимита, указанного в полях Burst Threshold. И сохраняем наше правило кнопкой Ok.

Применив это правило, пользователь с IP адресом 192.168.0.109 будет без всяких ограничений посещать веб-страницы или играть в онлайн игры и даже скачивать небольшие объемы информации. Но как только он начнет качать большой по объему файл со скоростью выше 5Мбит, то через указанное нами время (30сек) непрерывного скачивания, его скорость будет автоматически снижена до скорости указанной в ограничениях (10Мбит).

Хочу заметить, что ограничения могут быть созданы не только для одного IP адреса, но и для целой подсети по маске. Например, указав в поле Target Address 192.168.0.1/28, мы применим это правило для всех адресов подсети 192.168.0.1 — 192.168.0.14.

И еще одним полезным инструментом, который, на мой взгляд, должен быть описан в этой статье, является Torch. При помощи этого инструмента, можно определить, какой именно IP адрес, больше всего загружает сеть. Для этого в разделе Intefaces, мы выбираем интерфейс, расходующий больше всего ресурсов, или в качестве интерфейса выбираем наш бридж, что позволит получить данные со всех сетевых интерфейсов, объединенных в него. Нажимаем правой клавишей мыши и в самом конце открывшегося списка, нажимаем Torch. После чего открывается окно, где мы можем видеть все активные соединения всех пользователей, включая их IP адреса и объем трафика в битах/сек и количестве пакетов, проходящий в обе стороны.

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *